这篇文章上次修改于 279 天前,可能其部分内容已经发生变化,如有疑问可询问作者。
本文共 1158 个字,阅读时长 ≈ 3 分钟

Centos7.9配置LAMP环境

这几天搞服务器搞坏了,重装了好几次系统,这里记录一下配置LAMP环境的过程。


首先更新一下yum,先运行yum versionlock status查看是否有版本锁,若有的话则运行yum versionlock clear进行清除,然后运行yum -y update进行更新。

安装Apache

方法很简单,也不用更新yum源,先执行yum install httpd查看能否直接安装,如果显示no package found for httpd的话用yum --disableexcludes=all install httpd进行安装,否则直接安装就可以。安装完后用systemctl start httpd运行httpd。如果有安全组或者防火墙的话要打开80端口的通行许可,打开后可以在浏览器中输入你的ip,如果显示以下界面即为安装成功。

apache安装成功

安装MySQL

用命令直接安装即可

执行wget https://dev.mysql.com/get/mysql80-community-release-el7-6.noarch.rpm下载rpm包,然后执行

yum -y install mysql80-community-release-el7-6.noarch.rpm
yum -y install mysql-community-server --nogpgcheck

进行安装

有可能出现的错误

  1. 出现Package: mysql-community-server-5.7.38-1.el7.x86_64 (mysql57-community) Requires: mysql-community-common(x86-64) = 5.7.38-1.el7
  2. 出现Public key for mysql-community-server-5.7.37-1.el7.x86_64.rpm is not installed

安装PHP

因为我要用typecho,所以yum内的php版本太低,要更新一下rpm。

两个命令:

  • rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
  • rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

运行完后就可以直接通过yum install -y php72w php72w-cli php72w-common php72w-devel php72w-mysql来安装了,72是版本号,可以根据需求自行更改。

(wordpress可能还要再安装以下扩展包yum -y install php72w-gd php72w-imap php72w-ldap php72w-odbc php72w-pear php72w-xml php72w-xmlrpc